Вопрос по информатике:
С клавиатуры вводят слова.Составьте программу,которая выводит цифры этого числа .Например:семь нуль три один шесть четыре ,должно вывести 7 0 3 1 6 4
- 08.10.2017 18:55
- Информатика
- remove_red_eye 16898
- thumb_up 29
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
begin
var w1:=Arr('ноль','один','два','три','четыре','пять','шесть',
'семь','восемь','девять');
var w2:=Arr('0','1','2','3','4','5','6','7','8','9');
var a:=ReadlnString('->').ToWords;
foreach var w in a do begin
var i:=w1.FindIndex(p->p=w);
if i>=0 then Write(w2[i],' ')
end;
end.
Пример
-> семь ноль три один шесть четыре
7 0 3 1 6 4
- 09.10.2017 09:20
- thumb_up 17
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.