Вопрос по информатике:
ПОМОГИТЕ, ПОЖАЛУЙСТА! ЛЁГКАЯ ЗАДАЧА ПО ПАСКАЛЮ!Составьте программу, которая позволяет заменить в строке s слово t1 на слово t2. Строку s и слова t1 и t2 введите с клавиатуры.
Пример ввода:
На небе появилась туча.
туча
луна
Пример вывода:
На небе появилась луна.
- 19.11.2017 03:05
- Информатика
- remove_red_eye 6689
- thumb_up 39
Ответы и объяснения 1
s, t1, t2, st: string;
i: integer;
begin
readln(s);
readln(t1);
readln(t2);
if pos(t1, s) 0 then
i := pos(t1, s);
st := copy(s, 1, i - 1);
st := st + t2;
st := st + copy(s, i + length(t1), length(s));
writeln(st);
readln;
end.
- 20.11.2017 16:39
- thumb_up 41
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.