Вопрос по информатике:
Составить программу в Паскале.
Тестируется группа из n человек. Каждый вводит 1,если изучает английский,2-немецкий,3-французский,0-никакой. Определить сколько человек в каждой языковой группе.
С операторами for и case.
- 07.06.2016 23:19
- Информатика
- remove_red_eye 3159
- thumb_up 34
Ответы и объяснения 1
var
n,i,otv,l,m,h,k: integer;
begin
writeln ('сколько человек в группе');
read (n);
for i:=1 to n do
begin
writeln ('какой язык ты изучаешь: 1-англ,2-нем,3-франц,0-никакой');
read (otv);
case otv of
0: l:=l+1;
1: h:=h+1;
2: k:=k+1;
3: m:=m+1;
end;
end;
writeln ('английский язык изучает',h,'человек');
writeln ('немецкий язык изучает',k,'человек');
writeln ('французский язык изучает',m,'человек');
writeln (l,'человек не изучает никакой язык');
end.
- 08.06.2016 05:10
- thumb_up 18
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.