Вопрос по информатике:
Написать программу. В программу вводится n чисел, величину n задаёт пользователь, а также числа вводятся подряд.
1.Найти сумму введённых чисел.
2.Количество чисел равных 0.
3.Найти максимум и минимум среди введённых чисел. Нужно на языке С. Помогите пожалуйста.
- 16.05.2018 19:52
- Информатика
- remove_red_eye 9936
- thumb_up 17
Ответы и объяснения 1
program llllll;
var
A: array [-1000..1000] of integer;
n, i, b : integer;
begin
writeln('Введите количество чисел');
readln(n);
b:=0;
for i := 1 to n do
readln(A[i]);
for i := 0 to (n) do
b := b+ A[i];
write('Это сумма ');
writeln(b); // Это сумма.
b:=0;
for i := 1 to (n) do
begin
if A[i] = 0 then
b := b+1
end;
write('Это количество нулей ');
writeln(b) ;// это количество нулей
b:= -1001;
for i := 1 to (n) do
begin
if A[i] > b then
b := A[i]
end;
write('Это максимальное число ');
writeln(b); // Это максимальное число
b:= 1001;
for i := 1 to (n) do
begin
if A[i] < b then
b := A[i]
end;
write('Это минимальное число ');
writeln(b) // Это минимальное число
end.
- 17.05.2018 15:21
- thumb_up 3
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.