Вопрос по информатике:
На паскале нужно решить задачи
1.Задано трехзначное число. Составьте программу, с помощью которой определите произведение кубов цифр этого числа.
2.Задано трехзначное число. Составьте программу, с помощью которой определите , равняются ли в нем крайние числа.
- 09.09.2018 08:31
- Информатика
- remove_red_eye 6583
- thumb_up 23
Ответы и объяснения 1
var
a,e,d,s,p: integer;
begin
p:=1;
writeln ('введи трехзначное число');
read (a);
e:= (a mod 10);
s:=(a div 100);
d:=s*100-e;
p:=s*s*s*d*d*d*e*e*e;
writeln ('произведение кубов цифр числа равно',p);
if e=s then writeln ('первая цифра числа равна последней')
else
writeln ('первая цифра числа не равна последней');
end.
- 01.01.1970 00:00
- thumb_up 46
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.