Вопрос по информатике:
1)Составить программу для поиска наибольшего из 4 чисел.
2) Cоставить программу поиска наибольшего из трех чисел с учетом того, что числа могут быть равны.
Только плз чтобы там было типо такого : Var a,b,c,d max:integer
- 07.07.2018 01:52
- Информатика
- remove_red_eye 4317
- thumb_up 20
Ответы и объяснения 1
var
a, b, c, d, max: integer;
begin
readln(a, b, c, d);
if(a > b) and (a > c) and (a > d) then max := a
else if(b > a) and (b > c) and (b > d) then max := b
else if(c > a) and (c > b) and (c > d) then max := c
else max := d;
write(max);
end.
2)
var
a, b, c, max:
integer;
begin
readln(a, b, c);
if(a > b) and (a > c) then max := a
else if(b > a) and (b > c) then max := b
else max := c;
write(max);
end.
- 08.07.2018 03:16
- thumb_up 10
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.