Вопрос по информатике:
Напишите код программы на c++ для решения следующей задачи: дана матрица размером m*n. Вычислите суммы элементов каждого столбца. Определите наибольшее значение этих сумм и номер соответствующего столбца.
- 17.02.2017 13:46
- Информатика
- remove_red_eye 3169
- thumb_up 11
Ответы и объяснения 1
using namespace std;
int main()
{
int m, n;
// Выделение памяти и ввод матрицы
cout << "m = ";
cin >> m;
cout << "n = ";
cin >> n;
int **matrix = new int*[m];
for (int i = 0; i < m; ++i)
{
matrix[i] = new int[n];
for (int j = 0; j < n; ++j)
cin >> matrix[i][j];
}
// Вычисление суммы элементов каждого столбца. Определение наибольшего
// значения этих сумм и номер соответсвующего столбца
int sum, max_sum = INT_MIN, max_column;
for (int j = 0; j < n; ++j)
{
sum = 0;
for (int i = 0; i < m; ++i)
sum += matrix[i][j];
cout << "Column " << j << " - sum " << sum << endl;
if (sum > max_sum)
{
max_sum = sum;
max_column = j;
}
}
cout << "Max sum in column " << max_column << ". Max sum is " << max_sum << "." << endl;
// Удаление матрицы
for (int i = 0; i < m; ++i)
delete[] matrix[i];
delete[] matrix;
}
- 18.02.2017 07:33
- thumb_up 23
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.