Вопрос по информатике:
Составьте программу которая заполняет массив а[1..10] случайными целыми числами в диапазоне от 1 до 10 и вычислите сумму элементов массива с чётными значениями
- 24.02.2018 22:58
- Информатика
- remove_red_eye 8972
- thumb_up 19
Ответы и объяснения 1
// Внимание! В других версиях языка работа не гарантируется!
begin
var a:=ArrRandom(10,1,10); a.Println;
Writeln('S=',a.Where(x->x.IsEven).Sum)
end.
Пример
8 7 5 4 3 8 2 2 6 7
S=30
- 25.02.2018 12:37
- thumb_up 26
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.