Вопрос по информатике:
Напишите программу на языке Паскаль, которая будет вычислять значения 2 в степени 16, 18, 27 за минимальное возможное число умножений
- 03.05.2018 22:16
- Информатика
- remove_red_eye 714
- thumb_up 28
Ответы и объяснения 1
a = 2×2 ⇒ 2²
b = a×a ⇒ 2⁴
b = b×b ⇒ 2⁸
c = b×b ⇒ 2¹⁶ ⇒ вывод
2¹⁸ = 2¹⁶×2² ⇒ c×a ⇒ вывод
2²⁷ = 2¹⁶×2⁸×2²×2 ⇒ c×b×a×2 ⇒ вывод
// PascalABC.NET 3.2, сборка 1344 от 22.11.2016
begin
var a:=2*2;
var b:=a*a;
b:=b*b;
var c:=b*b;
Writeln('2^16=',c,', 2^18=',a*c,', 2^27=',2*a*b*c)
end.
Результат
2^16=65536, 2^18=262144, 2^27=134217728
- 04.05.2018 15:59
- thumb_up 34
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.