Вопрос по информатике:
Составьте программу, выводящую на экран все двузначные числа,у которых первая цифра в два раза больше второй.
- 16.05.2018 15:44
- Информатика
- remove_red_eye 18027
- thumb_up 38
Ответы и объяснения 1
using namespace std;
int main()
{
for(int i = 10; i < 100; i++)
{
if(i/10 == 2*(i%10))
cout << i << " ";
}
return 0;
}
Пример на С++
Но если надо на другом языке, то суть такова:
1)запускаешь цикл от 10 до 99(все двузначные числа) со счетчиком i например
2)внутри условие если i деленный нацело на 10(1 цифра этого числа )равен удвоенному значению остатка от деления i на 10 ( последняя цифра числа в 2 раза больше 1 должна быть)
то на экран выводится это число i
- 17.05.2018 09:32
- thumb_up 31
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.