Вопрос по информатике:
Составьте программу, которая формирует массив из пятнадцати случайных целых чисел от - 20 до 20 и четные числа делит на два, а нечетные - умножаем на три
Помогите, срочно!!
- 23.09.2017 11:14
- Информатика
- remove_red_eye 19056
- thumb_up 9
Ответы и объяснения 1
begin
for i:=1 to 15 do begin
a[i]:=Random(-20,20);
end;
write('Исходный массив ');
for i:=1 to 15 do begin
write(a[i]);write(' ');
end;
for i:=1 to 15 do begin
if (a[i] mod 2 = 0) then
a[i]:=a[i] div 2
else
a[i]*=2;
end;
writeln();
write('Преобразованный массив ');
for i:=1 to 15 do begin
write(a[i]);
write(' ');
end;
end.
- 24.09.2017 23:19
- thumb_up 14
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.