Вопрос по информатике:
Напишите программу которая для заданного числа определит сколько понадобится спичек чтобы выложить все цифры числа
Входные данные
1
239
Результат
2
16
- 06.01.2018 23:45
- Информатика
- remove_red_eye 9144
- thumb_up 21
Ответы и объяснения 2
i,s: integer;
st: string;
begin
write('число: '); readln(st);
s:=0;
for i:=1 to length(st) do
s:=s+a[ord(st[i])-48];
writeln('число спичек = ',s);
end.
- 08.01.2018 05:13
- thumb_up 21
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.