Вопрос по информатике:
Составьте программу, которая заполняет массив а 1..0 случайными целыми числами в диапазоне от 1 до 10 и вычесляет сумму элементов массива с четными значениями
- 06.07.2018 18:44
- Информатика
- remove_red_eye 10097
- thumb_up 36
Ответы и объяснения 1
const
g = 100;
var
a, i, sum: integer;
b: array[1..g] of integer; // Не совсем понятен был размер массива. Мною было принято решение задать значение 100. Вы можете изменить его в любое время.
// Поменяв значение в константе g.
begin
sum := 0;
for i := 1 to g do
begin
a := random(1, 10);
b[i] := a;
if b[i] mod 2 = 0 then
sum := b[i] + sum;
end;
write('Сумма массивов с четными значениями: ', sum)
end.
- 07.07.2018 13:46
- thumb_up 50
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.