Вопрос по информатике:
Программа на Паскале. Составить программу превода натурального числа N из 10 системы счисления в 8 систему счисления через рекурсию. Что число натуральное, проверять не надо. Если что то не понятно, спрашивайте.
- 26.08.2017 11:51
- Информатика
- remove_red_eye 13955
- thumb_up 35
Ответы и объяснения 1
if n > 1 then
decTo5(n div 5);
write(n mod 5);
end;
var n: integer;
begin
write('n = ');
readLn(n);
if (n > 0) then
decTo5(n)
else
writeLn('Error, n must > 0!');
writeLn;
end.
Извини меня если не правильно. Вроде так.
- 27.08.2017 12:04
- thumb_up 24
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.