Вопрос по информатике:
Составьте программу вычисления количества трёхзначных чисел-палиндромов.
- 03.06.2018 00:08
- Информатика
- remove_red_eye 16432
- thumb_up 13
Ответы и объяснения 2
ar: array of char;
i, c, j: integer;
b: boolean;
begin
b := true;
i := 100;
while true do
begin
s := i.ToString;
setlength(ar, i.ToString.Length);
ar := s.Reverse.ToArray;
for j := 1 to i.ToString.Length do
if (s[j] = ar[j - 1]) then else b := false;
if(b = true) then c := c + 1 else b := true;
if (i = 999) then break;
i := i + 1;
end;
write(c);
end.
- 04.06.2018 16:34
- thumb_up 51
Тем не менее, приведенная ниже программа решает задачу простым перебором.
// PascalABC.NET 3.2, сборка 1341 от 20.11.2016
begin
Writeln(Range(100,999).Where(x->(x mod 10)=(x div 100)).Count)
end.
Результат
90
- 05.06.2018 16:10
- thumb_up 39
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.