Вопрос по информатике:
ДАМ 40!!! БАЛЛОВ!!! ПОМОГИТЕ!!!
Написать программу, в которой вводится последовательность целых чисел, оканчивающаяся нулем (т.е. признак окончания ввода чисел в последовательности – ввод нуля). Программа должна посчитать и вывести количество отрицательных чисел в этой последовательности. Программу реализовать двумя способами: при помощи цикла с пред- и пост- условием.
Трудности с пониманием предмета? Готовишься к экзаменам, ОГЭ или ЕГЭ?
Воспользуйся формой подбора репетитора и занимайся онлайн. Пробный урок - бесплатно!
- 13.04.2016 00:29
- Информатика
- remove_red_eye 9855
- thumb_up 25
Ответы и объяснения 1
number: integer;
k: integer;
begin
repeat
write('number = ');
readln(number);
if number < 0 then k := k + 1;
until number = 0;
writeln('Кол-во отрицательных = ', k);
end.
- 15.04.2016 00:19
- thumb_up 32
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.