Вопрос по информатике:
Напишите программу на Pascal. Задан массив B[10]. Заполнить массив случайными числами(-10..10). Вывести на экран в строчку через пробел.
Вычислить сумму всех элементов массива и кол-тво чисел кратных двум.
- 08.03.2018 09:06
- Информатика
- remove_red_eye 3016
- thumb_up 10
Ответы и объяснения 1
begin
var b:=ArrRandom(10,-10,10); b.Println;
Writeln('Сумма элеменов массива равна ',b.Sum);
Writeln('Количество четных чисел равно ',b.Count(x->x.IsEven))
end.
Пример
1 10 3 -4 -10 -1 -6 0 -4 9
Сумма элеменов массива равна -2
Количество четных чисел равно 6
- 09.03.2018 12:26
- thumb_up 47
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.