Вопрос по информатике:
Напишите программу, находящую сумму арифметической прогрессии по заданным значениям первого элемента, разности и количества элементов последовательности.
- 15.07.2018 01:16
- Информатика
- remove_red_eye 14627
- thumb_up 35
Ответы и объяснения 1
Где а - это первый элемент последовательности
n - количество элементов
d -разность.
Составим программу на языке СИ
#include
#include
#include
int a,n,d;
double y;
int main(void)
{
printf("a=");
scanf("%d", &a);
printf("n=");
scanf("%d", &n);
printf("d=");
scanf("%d", &d);
y=((2*a+(n-1)*d)/2.0)*n;
printf("%lf", y);
}
- 16.07.2018 11:02
- thumb_up 3
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.