Вопрос по информатике:
Составьте программу, которая позволяет ввести элементы массива а [1...10] с клавиатуры и выводит на экран количество отрицательных элементов и их индексы.
P.S. не надо искать ответ в инете, т.к. там не правильно
- 15.09.2016 09:36
- Информатика
- remove_red_eye 715
- thumb_up 50
Ответы и объяснения 1
begin
var a:=ReadArrInteger('Введите 10 чисел, нажмите Enter'+#13#10,10);
var t:=a.Select((x,i)->(x,i+1)).Where(x->x[0]<0);
Write('Отрицательных- ',t.Count,'; их номера ');
t.Select(x->x[1]).Println
end.
Пример
Введите 10 чисел, нажмите Enter
3 14 0 -13 6 -11 -4 0 7 12
Отрицательных- 3; их номера 4 6 7
- 16.09.2016 23:53
- thumb_up 37
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.