Вопрос по информатике:
! ! ! ! ! HELP ! ! ! ! ! 34 балла
Составить программу,которая подсчитывает количество сочетаний 'темп' в произвольном тексте,введённом с клавиатуры.
- 10.03.2018 15:18
- Информатика
- remove_red_eye 9327
- thumb_up 36
Ответы и объяснения 2
begin
writeln('Введите строку:');
readln(s);
t:=s;
k:=0;
p:=pos('темп',t);
while p>0 do
begin
k:=k+1;
delete(t,p,4);
p:=pos('темп',t);
end;
writeln('k = ',k);
end.
Пример:
Введите строку:
темп медленный, темп средний, темп быстрый
k = 3
- 11.03.2018 07:45
- thumb_up 38
begin
var s:=ReadlnString('->');
var k:=RegEx.Matches(s,'Темп',RegexOptions.IgnoreCase).Count;
Writeln(k);
end.
Пример:
-> В темпе вальса телевизор "Темп" измерял свою температуру
3
- 12.03.2018 18:24
- thumb_up 36
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.