Вопрос по информатике:
Помогите решить. Напишите программу формирования массива размером 5х5 с помощью датчика случайных чисел замените в нем значения элементов с четной суммой индексов на значение второго элемента массива из первой строки. Выведите на экран исходный и измененный массив. (Паскаль абс) С объяснением
- 11.06.2018 14:20
- Информатика
- remove_red_eye 6191
- thumb_up 38
Ответы и объяснения 1
n=5;
var
a:array[1..n,1..n] of integer;
i,j:integer;
begin
//генератор случайных чисел. Диапазон от 1 до 10.
for i:=1 to n do
begin
for j:=1 to n do
begin
a[i,j]:=random(10)+1;
write(a[i,j]," ");
end;
writeln();
end;
//Проверка условия и переприсвоение, если верно.
for i:=1 to n do
for j:=1 to n do
begin
if (((i+j) mod 2)=0) then
a[i,j]:=a[1,2];
end;
//Вывод полученного массива.
for i:=1 to n do
begin
for j:=1 to n do
begin
write(a[i,j]," ");
end;
writeln();
end;
//Ожидание.
readln();
end.
- 12.06.2018 04:56
- thumb_up 25
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.