Вопрос по информатике:
Дан рекурсивный алгоритм:
function F(n: integer): integer;
begin
if n < 5 then
F:= F(n+3) + F(2*n) + F(3*n div 2)
else
F:= n + 2;
end;
Чему будет равно значение, вычисленное алгоритмом при выполнении вызова F(3)?
- 19.04.2018 16:34
- Информатика
- remove_red_eye 9635
- thumb_up 41
Ответы и объяснения 1
begin
Writeln('Вход с n=',n);
if n < 5 then
Result := F(n + 3) + F(2 * n) + F(3 * n div 2)
else
Result := n + 2;
Writeln('Выход для n=',n,', F=',Result)
end;
begin
Writeln(F(3))
end.
Результат
Вход с n=3
Вход с n=6
Выход для n=6, F=8
Вход с n=6
Выход для n=6, F=8
Вход с n=4
Вход с n=7
Выход для n=7, F=9
Вход с n=8
Выход для n=8, F=10
Вход с n=6
Выход для n=6, F=8
Выход для n=4, F=27
Выход для n=3, F=43
43
- 20.04.2018 06:05
- thumb_up 31
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.