Вопрос по информатике:
После обучения Архимед и Эратосфен переписывались еще много лет. Помогите определить, сколько денег нужно заплатить за отправку бандероли в древней Греции, если известно, что за бандероль весом до 50 грамм взимается 10 драхм (дренегреческая валюта), а за каждые следующие полные или неполные 50 грамм еще по 5 драхм.
Напишите программу, вычисляющую, какое наименьшее число монет по 10, 4 и 1 драхме надо заплатить за отправку бандероли весом w грамм.(Free Pascal)
- 20.07.2017 10:45
- Информатика
- remove_red_eye 8652
- thumb_up 49
Ответы и объяснения 1
------------------------
program aaa;
const n=50;
var w, c, x, d10, d4, d1: integer;
begin
writeln ('Введите вес бандероли');
readln (w);
if w <= n
then c:=10
else
if w mod n = 0
then c:=10+((w div n)-1)*5
else c:=10+5+((w div n)-1)*5;
d10:= c div 10;
d4:= (c-10*d10) div 4;
d1:= (c-d10*10-d4*4);
writeln ('стоимость бандероли: ',c,' драхм');
writeln;
writeln ('для оплаты нужно не менее');
writeln (d10:10,' монет по 10 драхм');
writeln (d4:10,' монет по 4 драхмы');
writeln (d1:10,' монет по 1 драхме');
end.
------------------
Результат работы программы:
Введите вес бандероли 100
стоимость бандероли: 15 драхм
для оплаты нужно не менее
1 монет по 10 драхм
1 монет по 4 драхмы
1 монет по 1 драхме
- 21.07.2017 02:50
- thumb_up 1
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.