Вопрос по информатике:
Написать программу на Паскаль:
1) Составить программу, которая при заданных значениях x и y вычисляет функции A с точностью 10^-3
A=((x*y)/(x+y))/(1+√(x²-x-4));
2) Составить программу, которая запрашивает ввод коэффициентов a,b,c,d уравнение вида "ax+b=c+dx", а после ввода коффициентов напечатает или решение или сообщение о том, что решение не существует, коэффициенты уравнения вводятся в соответствии одному из этих случаев.
- 26.06.2017 09:41
- Информатика
- remove_red_eye 4793
- thumb_up 38
Ответы и объяснения 1
var x,y,a:real;
begin
write('x = ');
readln(x);
write('y = ');
readln(y);
if x*x-x-4>=0 then
begin
a:=((x*y)/(x+y))/(1+sqrt(x*x-x-4));
writeln('a = ',a:5:3);
end
else writeln('Корень из отрицательного числа');
end.
2)
var a,b,c,d:real;
begin
writeln('Введите a, b, c, d:');
readln(a,b,c,d);
if (a=d)
then if (c=b) then writeln('Бесконечно много решений')
else writeln('Решения нет')
else writeln('x = ',(c-b)/(a-d));
end.
Пример:
Введите a, b, c, d:
2 1 4 3
x = -3
- 27.06.2017 01:37
- thumb_up 17
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.