Вопрос по информатике:
Нужно написать программу на Pascal.Программа должна посчитать среднюю оценку ученика.Например: "Введите ваши оценки: 54454",программа должна вывести: "Ваш средний балл: 4,4".Человек может вводить сколько угодно значений
- 14.09.2018 09:27
- Информатика
- remove_red_eye 6771
- thumb_up 43
Ответы и объяснения 1
Var marks:string; i,m,c,s,k:integer;
begin
write('Введите ваши оценки: ');
readln(marks);
s:=0; k:=0;
for i:=1 to length(marks) do
if marks[i] in ['2'..'5']
then begin val(marks[i],m,c); s:=s+m; k:=k+1 end;
writeln('Ваш средний балл: ',s/k);
end.
Пример:
Введите ваши оценки: 54454
Ваш средний балл: 4.4
- 16.09.2018 00:02
- thumb_up 34
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.