Вопрос по информатике:
Написать программу на паскале для определения числа членов ряда,вошедших в сумму.Исходные данные 0.62,точность вычисления 10^-4.
- 22.03.2018 00:55
- Информатика
- remove_red_eye 18114
- thumb_up 14
Ответы и объяснения 1
Const eps=1e-4;
var n,z:integer; x,sx,an,s:real;
begin
x:=0.62;
sx:=sin(x);
n:=1; z:=-1;
an:=1; s:=0;
while abs(an)>eps do
begin
z:=-z;
n:=n+1;
an:=z*sx/(n*(n*n-1));
s:=s+an;
end;
writeln('k = ',n-1,' s = ',s);
end.
Результат:
k = 17 s = 7.92376332816429E-002
- 23.03.2018 17:19
- thumb_up 23
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.