Вопрос по информатике:
Написать программу нахождение максимального и минимального значения массива.Программу нужно сделать в Паскаль.
ПРОШУ ПОМОГИТЕ
- 17.12.2017 15:33
- Информатика
- remove_red_eye 19522
- thumb_up 49
Ответы и объяснения 1
Тут все
const
handsfree = true;
var
a: array[1..100] of real;
i, n: integer;
min, max: real;
sum, product, harmonic: real;
k: integer;
begin
{ввод массива}
if handsfree then
n := random(20) + 5
else begin
write('n = ');
readln(n);
end;
writeln('Данные массива:');
for i := 1 to n do
begin
if handsfree then begin
a[i] := random(100) - 50;
write(a[i], ' ');
end
else readln(a[i]);
end;
writeln();
{подсчет элементов}
k := 0;
for i := 1 to n do
if a[i] > 5 then k := k + 1;
writeln(k);
{минимум и максимум}
max := a[1];
min := a[1];
for i := 1 to n do
begin
if max < a[i] then max := a[i];
if min > a[i] then min := a[i];
end;
writeln('max = ', max);
writeln('min = ', min);
{подсчет суммы и произведения и агригатов}
sum := 0;
product := 1;
harmonic := 1;
k := 0;
for i := 1 to n do
begin
if true then {если нужен фильтр}
begin
sum := sum + a[i];
product := product * a[i];
harmonic := harmonic + 1 / a[i];
k := k + 1;
end;
end;
writeln('sum = ', sum);
writeln('product = ', product);
writeln('average = ', sum / n);
writeln('average (selected) = ', sum / k);
writeln('harmonic mean = ', n / harmonic);
writeln('harmonic mean (selected) = ', k / harmonic);
{изменение элементов}
for i := 1 to n do
begin
if a[i] < 0 then
a[i] := abs(a[i]);
write(a[i], ' ');
end;
end.
- 18.12.2017 13:32
- thumb_up 32
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.