Вопрос по информатике:
Найти средние арифметические положительных и отрицательных элементов массива,написать программу в паскале
- 27.07.2017 16:06
- Информатика
- remove_red_eye 12793
- thumb_up 43
Ответы и объяснения 1
const
handsfree = false;
var
a: array[1..100] of real;
i, n: integer;
sum_pos, sum_neg: real;
k_pos, k_neg: integer;
begin
{ввод массива}
if handsfree then
n := random(20) + 5
else begin
write('n = ');
readln(n);
end;
writeln('Данные массива:');
for i := 1 to n do
begin
if handsfree then begin
a[i] := random(100) - 50;
write(a[i], ' ');
end
else readln(a[i]);
end;
writeln();
{подсчет}
sum_pos := 0;
k_pos := 0;
sum_neg := 0;
k_neg := 0;
for i := 1 to n do
begin
if a[i] > 0 then
begin
sum_pos := sum_pos + a[i];
k_pos := k_pos + 1;
end;
if a[i] < 0 then
begin
sum_neg := sum_neg + a[i];
k_neg := k_neg + 1;
end;
end;
writeln('average (positives) = ', sum_pos / k_pos);
writeln('average (negatives) = ', sum_neg / k_neg);
end.
- 28.07.2017 07:25
- thumb_up 13
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.