Вопрос по информатике:
Напишите программу подсчета количества и суммы нечетных элементов массива
- 21.08.2018 06:41
- Информатика
- remove_red_eye 14402
- thumb_up 49
Ответы и объяснения 2
Код Pascal1 2 3 4 5 6 7 8 9 10 11 12 begin var Size := ReadLnInteger('Размер массива ='); var A : array of Integer; SetLength(A, Size); for var i := 0 to pred(Size) do A[i] := ReadLnInteger('A[' + (i+1).ToString + '] ='); WriteLn('Введён массив A = ', A); var count := 0; for var i := 0 to pred(Size) do if Not odd(A[i]) then count += 1; WriteLn('В массиве чётных элементов: ', count); var max := 0; for var i := 1 to pred(Size) do if A[max] < A[i] then max := i; var k := ReadLnInteger('k = '); A[max] *= k; WriteLn('Массив A = ', A); end.
- 22.08.2018 18:24
- thumb_up 31
Если что нибудь нужно пояснить или изменить, пиши.
const n=10; //вместо 10 количество ячеек в массиве (любое)
var a: array [1..n] of integer;
i,k,s: integer;
begin
randomize;
for i:=1 to n do begin
a[i]:=random(100);
if i mod 20 then
begin k:=k+1; s:=s+a[i]; end; end;
writeln(k,' ',S)
end.
- 23.08.2018 10:56
- thumb_up 43
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.