Вопрос по информатике:
Помогите не могу написать программу на C#
Напишите программу которая определяет в заданном числе заданную цифру.\
Цифра это числа от 0 до 9
- 10.02.2017 09:22
- Информатика
- remove_red_eye 11421
- thumb_up 39
Ответы и объяснения 1
Using System;
//Напишите программу которая определяет в заданном числе заданную цифру.
//Цифра это числа от 0 до 9
namespace NoNamespace {
internal class Program {
private static void Main() {
Console.WriteLine(IsDigitInNumber(123.8, 2));
Console.WriteLine(IsDigitInNumber(1, 1));
Console.WriteLine(IsDigitInNumber(103.28, 2));
Console.ReadLine();
}
private static int IsDigitInNumber(double number, uint digit) {
if (0 > digit || digit > 9)
throw new Exception("Не верный формат цифры");
var n = number.ToString().IndexOf(digit.ToString());
var p = number.ToString().IndexOf(".");
//Console.WriteLine($"number = {number} digit = {digit} n = {n} p = {p} A = {p-n}");
return p-n;
}
}
}
- 11.02.2017 19:13
- thumb_up 20
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.