Вопрос по информатике:
Необходима Программа на языке Паскаль
В классе проведено тестирование. Максимально можно было набрать 100 баллов. Известны баллы, набранные каждым из учеников. Определите, сколько учеников в классе набрали:
Баллы, отклоняющиеся от среднего значения не более чем на 10%.
- 05.10.2015 13:40
- Информатика
- remove_red_eye 10460
- thumb_up 16
Ответы и объяснения 1
Var a:array[1..100] of real;
i,k,n:integer;
sr,pr,s:real;
begin
write('Введите кол-во учеников в классе: '); readln(n);
writeln('Введите баллы учеников: ');
for i:=1 to n do
read(a[i]);
s:=0;
for i:=1 to n do
s:=s+a[i];
sr:=s/n; pr:=sr/10;
for i:=1 to n do
if (a[i]sr-pr) then
inc(k);
writeln('Кол-во баллов, отклоняющиеся от срзнач. не более чем на 10%: ',k);
end.
- 06.10.2015 00:51
- thumb_up 16
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.