Вопрос по информатике:
Помогите написать программу, которая считает периметр двумерного массива, пожалуйста? (С++)
- 14.03.2018 23:52
- Информатика
- remove_red_eye 6979
- thumb_up 41
Ответы и объяснения 1
#include
#include
#include
using namespace std;
int main() {
const int n = 3;
const int m = 4;
int a[n][m];
int s=0;
cout << "Исходный массив" <
for (int i = 0; i < n; i++){
for (int j = 0; j < m; j++){
a[i][j]=10+(51.0 / RAND_MAX) * rand();
cout << fixed << setw (7) << a[i][j];
}
cout <
for (int j = 0; j < m; j++)
s = s+a[0][j]+a[n-1][j];
for (int i = 1; i < n-1; i++)
s = s+a[i][0]+a[i][m-1];
cout << "s = " << s << endl;
}
Пример:
Исходный массив
55 33 24 41
50 60 41 11
17 33 45 50
s = 359
- 15.03.2018 22:17
- thumb_up 30
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.