Вопрос по информатике:
Изучая английский язык, студент каждый день учит столько слов, сколько за два предыдущих дня и еще 3 слова дополнительно. Каждые 10 дней студент забывает 5 % выученных слов. Через сколько дней студент будет знать более 1500 слов, если в первый и во второй день он выучил по 6 слов?
Написать программу на PascalABC.NET
- 23.08.2017 02:21
- Информатика
- remove_red_eye 11005
- thumb_up 50
Ответы и объяснения 1
//PascalABC.Net 3.1.0.1200
var
yesterday, before_yesterday, all, this_day, days: integer;
begin
yesterday := 6;
before_yesterday := 6;
all := yesterday + before_yesterday;
days := 2;
repeat
days += 1;
this_day := yesterday + before_yesterday + 3;
all += this_day;
if days mod 10 = 0 then all := trunc(all * 0.95);
before_yesterday := yesterday;
yesterday := this_day;
until all > 1500;
writeln('days = ', days);
end.
- 24.08.2017 11:36
- thumb_up 36
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.