Вопрос по информатике:
Найдите потерянное число. Вам даны все целые число от 1 до N+1, кроме одного. Найдите отсутствующее число. Формат входных данных: в первой строке входных данных записано целое число N (1<=N<=100,000). Во второй строке через пробел даны N целых чисел в диапазоне от 1 до N+1.
- 10.07.2018 03:02
- Информатика
- remove_red_eye 12535
- thumb_up 38
Ответы и объяснения 1
//PascalABC.Net 3.1.0.1200
var
f: TextFile;
begin
if not FileExists('input.txt') then Exit;
Reset(f, 'input.txt');
var n := ReadlnInteger(f);
var a := ArrFill(n + 1, 0);
for var i := 1 to n do
a[i - 1] := ReadInteger(f);
a[n] := n + 2;
println(a);
a.Sort;
println(a);
for var i := 1 to n + 1 do
if a[i - 1] i then begin
writeln(i);
break;
end;
end.
- 11.07.2018 12:23
- thumb_up 50
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.