Вопрос по информатике:
ПОЖАЛУЙСТА РЕШИТЕ !!! А не пишите какой-то бред решите хотя бы 10 задач!!!
1. Дано целое число N. Написать программу, заменяющую его нулем, если число меньше нуля, и увеличивающую его на 4, если число неотрицательное.
2. Даны целые числа A и B. Написать программу, которая выводит число 1, если числа равны, и число 0 в противном случае.
3. Даны целые числа A, В и С. Написать программу, подсчитывающую количество неотрицательных чисел среди данных.
4. Даны целые числа A, В и С. Написать программу, подсчитывающую сумму положительных чисел среди данных.
5. Даны числа A, В и С. Написать программу, выводящую их в убывающем порядке.
6. Даны целое трехзначное число N и целое число k. Написать программу, подсчитывающую сумму тех цифр числа N, которые больше k.
7. Дано натуральное число N. Написать программу, подсчитывающую сумму 1+2+3+…+N.
8. Даны натуральные числа А и В (В 9. Дано натуральное число N. Написать программу, выводящую на экран последовательность натуральных чисел от N до 1.
10. Дано натуральное число N. Написать программу для вычисления суммы .
11. Дано натуральное число N. Написать программу для вычисления суммы .
12. Дано натуральное число N (N<10). Написать программу, для вычисления суммы вида 0,1+0,2+0,3+… (N слагаемых).
13. Дано натуральное число N. Написать программу, выводящую на экран последовательность квадратов всех чисел от 1 до N.
14. Дано натуральное число N. Написать программу, выводящую последовательность первых N нечетных чисел.
15. Дано N натуральных чисел. Написать программу, вычисляющую их среднее арифметическое. Число N вводится перед всеми остальными.
16. Дана последовательность целых чисел, заканчивающаяся нулем (в самой последовательности нулей нет). Написать программу, которая подсчитывает количество чисел в последовательности.
17. Дана последовательность целых чисел, заканчивающаяся нулем (в самой последовательности нулей нет). Написать программу, которая подсчитывает количество четных чисел в последовательности (число 0 для вычисления результата считать не надо).
18. Дана последовательность целых чисел, заканчивающаяся нулем и содержащая еще один нуль в произвольном месте. Написать программу, которая подсчитывает количество чисел между нулями.
19. Дана последовательность целых чисел, заканчивающаяся нулем (в самой последовательности нулей нет). Написать программу, которая выводит последнее ненулевое число последовательности.
20. Дано целое число N (>0). Если оно является степенью числа 3, то вывести true, если не является – вывести false.
21. Дана последовательность целых чисел, заканчивающаяся нулем (в самой последовательности нулей нет). Написать программу, находящую максимальное число последовательности.
22. Написать программу, определяющую количество трехзначных натуральных чисел, сумма цифр которых равна заданному числу N (>0).
23. Дана последовательность целых чисел, заканчивающаяся нулем (в самой последовательности нулей нет). Написать программу, выводящую все числа последовательности, кратные трем.
24. Как и многие другие девочки, Маша любит разные гадания. Некоторое время назад Маша узнала новый способ гадать на числах – для какого-нибудь интересующего ее натурального числа N надо посчитать сумму всех чисел, на которые N делится без остатка. Маша не очень любит арифметику, и попросила вас написать программу, которая автоматизирует процесс гадания.
Ввод: натуральное число N (N ≤ 1000).
Вывод: сумма всех натуральных делителей числа N.
25. Петя и Катя – брат и сестра. Петя – студент, а Катя – школьница. Петя помогает Кате по математике. Он задумывает два натуральных числа X и Y (X,Y≤1000), а Катя должна их отгадать. Для этого Петя делает две подсказки. Он называет сумму этих чисел S и их произведение P. Помогите Кате отгадать задуманные Петей числа.
Ввод: два натуральных числа S и P, разделенные пробелом.
Вывод: два числа Х и Y, загаданные Петей. Числа следует вывести в порядке неубывания своих значений, разделенные пробелом.
26. Даны два натуральных числа A и B. Требуется найти их наибольший общий делитель (НОД).
Ввод: натуральные числа A и B через пробел (A, B ≤ 109).
Вывод: НОД чисел А и В.
- 11.01.2017 15:33
- Информатика
- remove_red_eye 4747
- thumb_up 39
Ответы и объяснения 1
1)
var
n:integer;
begin
readln(n);
if(n<0)then write(0)
else write(n+4);
end.
2)
var
a, b: integer;
begin
readln(a, b);
if(a = b) then
write(1)
else
write(0);
end.
3)
var
a, b, c, s: integer;
begin
s := 0;
readln(a, b, c);
if(a >= 0) then s := s + 1;
if(b >= 0) then s := s + 1;
if(c >= 0) then s := s + 1;
write(s);
end.
4)
var
a, b, c, s: integer;
begin
s := 0;
readln(a, b, c);
if(a > 0) then s := s + a;
if(b > 0) then s := s + b;
if(c > 0) then s := s + c;
write(s);
end.
5)
var
a, b, c: integer;
begin
readln(a, b, c);
if (a < b) then swap(a, b);
if (a < c) then swap(a, c);
if (b < c) then swap(b, c);
write(a, ' ', b, ' ', c);
end.
6)
var n, k, s, i: integer;
begin
s := 0;
readln(n, k);
for i := 1 to n.ToString.Length do
if(strtoint(n.ToString[i]) > k) then s := s + strtoint(n.ToString[i]);
write(s);
end.
7)
var n, s, i: integer;
begin
s := 0;
readln(n);
for i := 1 to n do
s := s + i;
write(s);
end.
9)
var n, i: integer;
begin
readln(n);
for i := n downto 1 do
write(i);
end.
12
var
n, i: integer;
s: real;
begin
s := 0;
readln(n);
for i := n downto 1 do
s:=s+(0.1*i);
write(s);
end.
13)
var n, i: integer;
begin
readln(n);
for i := 1 to n do
write(sqr(i), ' ');
end.
14)
var
n, i, c: integer;
begin
i := 1;
c := 0;
readln(n);
while (c n) do
begin
if(i mod 3 = 0) then begin write(i, ' ');c := c + 1; end;
i := i + 1;
end;
end.
15)
var
n, i, a: integer;
c: real;
begin
i := 1;
c := 0;
readln(n);
for i := 1 to n do
begin
read(a);
c := c + a;
end;
write(c / n)
end.
16)
var
n, i, a: integer;
begin
i := 1;
while true do
begin
read(a);
if(a = 0) then break;
n := n + 1;
end;
write(n)
end.
- 12.01.2017 20:10
- thumb_up 32
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.