Вопрос по информатике:
Даны натуральные числа n, a1,..,an. Составьте программу, которая определяет количество членов последовательности a1,..,an, с чётными порядковыми номерами и нечётными значениями.
- 04.06.2018 17:02
- Информатика
- remove_red_eye 7261
- thumb_up 12
Ответы и объяснения 1
Var i,n,k:integer;
a:array[1..100] of integer;
begin
readln(n);
for i:=1 to n do
read(a[i]);
for i:=1 to n do
if odd(a[i]) and not odd(i) then inc(k);
writeln('Кол-во элементов с четн.номерами и нечетн.значениями: ',k);
end.
- 06.06.2018 00:26
- thumb_up 36
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.