Вопрос по информатике:
Помогите с программой пожалуйста! на языке паскаль . Напишите программу, которая заполняет массив из 20 элементов случайными числами на отрезке [–100; 100] и находит в каждой половине массива пару соседних элементов, сумма которых максимальна .
- 17.07.2016 00:52
- Информатика
- remove_red_eye 6030
- thumb_up 20
Ответы и объяснения 1
Var a:array[1..20] of integer;
i,max1,ind1,max2,ind2:integer;
begin
randomize;
for i:=1 to 20 do begin
a[i]:=random(200)-100;
write(a[i]:4);
end;
writeln;
max1:=a[1]+a[2];
for i:=2 to 9 do
if a[i]+a[i+1]>max1 then
begin
max1:=a[i]+a[i+1];
ind1:=i;
end;
max2:=a[11]+a[12];
for i:=12 to 19 do
if a[i]+a[i+1]>max2 then
begin
max2:=a[i]+a[i+1];
ind2:=i;
end;
write('Сумма максимальна между ',ind1,' и ', ind1+1, ' элементом в первой половине и между ',ind2,' и ',ind2+1,' во второй половине массива');
end.
- 17.07.2016 09:30
- thumb_up 37
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.