Вопрос по информатике:
Авиакомпания перевезла в первый год 21 тыс. пассажиров.Каждый следующий год увеличила перевозки на 4%.Сколько тыс. пассажиров перевезено за 5 лет?Через
сколько лет удвоится пассажиропоток.
Помогите с задаче по информатике , напишите программу.
- 05.07.2018 05:41
- Информатика
- remove_red_eye 9773
- thumb_up 44
Ответы и объяснения 1
Var n,s,k:integer;
begin
// 1
n:=21000;
s:=n;
for k:=2 to 5 do
begin
n:=round(n*1.04);
s:=s+n;
end;
writeln('s = ',s);
// 2
n:=21000; k:=1;
while n<2*21000 do
begin
n:=round(n*1.04);
k:=k+1;
end;
writeln('k = ',k,' n = ',n);
end.
Результат:
s = 113745
k = 19 n = 42544
- 06.07.2018 22:54
- thumb_up 23
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.