Вопрос по информатике:
Будем считать, что у осы 6 ног, у паука – 8, у тигра – 4 и у кенгуру – 2. На вход программе подаётся общее количество ног – N. Требуется подсчитать, скольк ими способами можно составить это ко- личество, используя описанных выше животных. Если не удастся найти ни одного способа, то сообщить об этом специальным выводом: IMPOSSIBLE
- 22.12.2016 16:48
- Информатика
- remove_red_eye 3903
- thumb_up 11
Ответы и объяснения 1
Var n,k8,k6,k4,k2,k:integer;
begin
write('n = ');
readln(n);
if n mod 2 = 1
then writeln('IMPOSSIBLE')
else begin
k:=0;
for k8:=0 to n div 8 do
for k6:=0 to (n-8*k8) div 6 do
for k4:=0 to (n-8*k8-6*k6) div 4 do
begin
k2:=(n-8*k8-6*k6-4*k4) div 2;
k:=k+1;
end;
writeln('k = ',k);
end;
end.
Пример:
n = 10
k = 6
- 23.12.2016 08:29
- thumb_up 42
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.