Вопрос по информатике:
Составить программу на Паскале. В массиве хранится информация о стоимости каждой из M книг. Определить количество самых дешевых книг(с одинаковой минимальной ценой)
- 27.07.2018 15:43
- Информатика
- remove_red_eye 16851
- thumb_up 25
Ответы и объяснения 1
Var mas:array of integer; min,kol ,j, i,n:integer;
begin
Randomize; min:=0;kol:=0;
write('n:' );
readln(n);
setlength(mas,length(mas)+n);///динамический массив вы можете заменить на статический
For i:= 0 to high(mas) do
mas[i]:=Random(50);
min:=mas[0];
for j:=0 to high(mas) do//ищем минимальную ценну
if min>mas[j] then
min:=mas[j] ;
For i:= 0 to high(mas) do
if min=mas[i] then//ищем количество книг с минимальной ценой
inc(kol);
write('kolvo min ',kol);
readln;
end.
- 28.07.2018 19:42
- thumb_up 40
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.