Вопрос по информатике:
Пользователь вводит четыре числа. Найдите наибольшее четное число среди них. Если оно не существует, выведите фразу "not found". Сделать в паскаль
- 24.01.2017 14:21
- Информатика
- remove_red_eye 16345
- thumb_up 18
Ответы и объяснения 2
Var a:array[1..4] of integer;
i,max:integer;
b:boolean;
begin
b:=false;
for i:=1 to 4 do
read(a[i]);
max:=a[1];
for i:=1 to 4 do
if (not odd(a[i])) and (a[i]>=max) then begin
max:=a[i];
b:=true;
end;
if b then write('',max) else write('not found');
end.
- 26.01.2017 00:39
- thumb_up 12
Var
a: array[1..4] of integer;
i, max: integer;
begin
for i := 1 to 4 do
readln(a[i]);
max := a[1];
for i := 1 to 4 do
if (a[i] mod 2 = 0) and (a[i] >= max) then
max := a[i];
if max mod 2 = 0 then
writeln(max)
else
writeln('not found');
end.
- 26.01.2017 05:28
- thumb_up 49
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.