Вопрос по информатике:
Математик решил обновить линолеум в своей квартире. Перед тем как отправиться в магазин, математик измерил длину и ширину двух комнат и записал четыре числа на листок. Когда он вмагазине попытался определить, сколько квадратным метров линолеума ему нужно купить, онобнаружил, что забыл, каким комнатам соответствуют каждое из чисел. Тогда математик решил купитьстолько линолеума, чтобы его хватило покрыть пол в комнатах, какая бы ни была путаница в размерах комнат.Напишите программу, которая определит максимальную суммарную площадь двух комнат поизвестным размерам. Вводятся четыре целых числа в диапазоне от 1 до 20 — размеры двух комнатв метрах в неизвестном порядке.Вывести одно целое число — максимальную суммарную площадь комнат в квадратных метрах.
Пример ввода Пример вывода
5 2 3 4 26
Пояснение к примеру: максимальная площадь 26 квадратных метров получается, если размеры комнат 4x5 и 2x3.
- 01.02.2016 11:18
- Информатика
- remove_red_eye 7163
- thumb_up 47
Ответы и объяснения 1
Program aaa;
var
a,b,c,d,s: real;
begin
writeln('введите a, b, c, d');
readln(a,b,c,d);
if (a*b+c*d)>=(a*c+b*d)
then
if (a*b+c*d)>=(a*d+b*c)
then s:=a*b+c*d
else s:=a*d+b*c
else
if (a*c+b*d)>=(a*d+b*c)
then s:=a*c+b*d
else s:=a*d+b*c;
writeln(s)
end.
- 02.02.2016 16:06
- thumb_up 16
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.