Вопрос по информатике:
Составить программу вычисления значений функции F(x) на отрезке [a,b] с шагом h. Результат представить в виде таблицы, первых столбец которой – значения аргумента, второй – соответствующие значения функции. Программу составить двумя способами: с использованием цикла с предусловием и с использованием цикла с постусловием. F(x) ctg x+ 1
- 05.07.2018 09:35
- Информатика
- remove_red_eye 6269
- thumb_up 6
Ответы и объяснения 1
Var a,b,h,x,x1,x2:real;
function F(x:real):real;
begin
F:=cos(x)/sin(x)+1;
end;
begin
writeln('Функция: F(x)=ctgx+1');
write('Введите крайние точки отрезка: '); readln(x1,x2);
write('Введите шаг: '); readln(h);
writeln('| x | F(x) |');
writeln('_________________');
if x1>x2 then begin
a:=x2; b:=x1; end
else begin
a:=x1; b:=x2; end;
x:=a;
while x<=b do
begin
writeln('|',x:7:3,'|',f(x):7:3,'|');
x:=x+h;
end;
end.
- 06.07.2018 20:37
- thumb_up 9
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.