Вопрос по информатике:
На вход программе подаётся последовательность символов, заканчивающаяся точкой (точка – признак конца и в последовательность не входит). Проверить, правильно ли в данной последовательности расставлены круглые скобки (то есть, справа от каждой открывающей есть соответствующая закрывающая, а слева от каждой закрывающей есть соответствующая открывающая).
- 23.08.2017 12:55
- Информатика
- remove_red_eye 8975
- thumb_up 34
Ответы и объяснения 1
Var s:string; k,i:integer; b:boolean;
begin
writeln('s = ');
readln(s);
k:=0; i:=1;
b:=true;
while s[i]'.' do
begin
case s[i] of
'(' : k:=k+1;
')' : k:=k-1;
end;
if k<0 then b:=false;
i:=i+1;
end;
if b and (k=0) then writeln('Все ОК') else writeln('Есть ошибки');
end.
Пример:
s = ((a+b)/(2b-3a))(a/b).
Все ОК
- 24.08.2017 02:09
- thumb_up 18
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.