Вопрос по информатике:
Задан двумерный массив, имеющий N строк и M столбцов. Определите, является ли строка номер N1 равной строке номер N2. Если ДА - вывести Yes и сумму элементов строки N1. Если НЕТ - вывести No и сумму элементов строки N2.
Формат ввода:
N M (N<=10, M<=12)
a[1,1] a[1,2] ... a[1,M]
a[2,1] a[2,2] ... a[2,M]
...
a[N,1] a[N,2] ... a[N,M]
N1 N2
Пример ввода:
3 4
1 2 3 4
1 2 3 4
1 2 4 4
1 2
Пример ввода:
3 4
1 2 3 4
1 2 3 5
1 2 3 4
1 2
Формат вывода:
Yes SumN1
или
No SumN2
Пример вывода:
Yes 10
Пример вывода:
No 11
SumN1 - сумма всех элементов строки N1
SumN2 - сумма всех элементов строки N2
- 21.08.2015 04:57
- Информатика
- remove_red_eye 9217
- thumb_up 16
Ответы и объяснения 1
Var a:array[1..10,1..12] of integer;
n,m,n1,n2,i,j,s1,s2:integer;
b:boolean;
begin
readln(n,m);
for i:=1 to n do
for j:=1 to m do read(a[i,j]);
readln(n1,n2);
s1:=0; s2:=0; b:=true;
for j:=1 to m do
begin
s1:=s1+a[n1,j]; s2:=s2+a[n2,j];
if a[n1,j]a[n2,j] then b:=false;
end;
if b then write('YES, s1 = ',s1) else write('NO, s2 = ',s2);
end.
Пример:
3 4
1 2 3 4
2 3 1 4
1 2 3 4
1 3
YES, s1 = 10
- 22.08.2015 20:46
- thumb_up 4
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.