Вопрос по информатике:
Написать программу на Pascal,для вычисления значения функции F(x)=
а) =0.5 при x
-1
б)=0 при x=0
в)=x+3 при x<-1
x=[-3;4] с шагом 0,5
- 01.07.2018 21:05
- Информатика
- remove_red_eye 3962
- thumb_up 48
Ответы и объяснения 2
Var x:real;
begin
x:=-3;
while x<=4 do begin
if x>=1 then writeln('F(x) = ',sqr(x)/2);
if x=0 then writeln('F(x) = 0');
if x<-1 then writeln('F(x) = ',x+3);
x:=(x+0.5);
end
end.
- 02.07.2018 01:35
- thumb_up 29
На самом деле условие F(х)=0 при х=0 лишнее, поскольку значение F(x)=0.5x² при x≥-1 и так дает F(0)=0.
var
x,F:real;
begin
x:=-3;
while x<4.01 do begin
if x<-1 then F:=x+3
else F:=0.5*x*x;
Writeln('x=',x:4:1,', F=',F:5:3);
x:=x+0.5
end
end.
Результат
x=-3.0, F=0.000
x=-2.5, F=0.500
x=-2.0, F=1.000
x=-1.5, F=1.500
x=-1.0, F=0.500
x=-0.5, F=0.125
x= 0.0, F=0.000
x= 0.5, F=0.125
x= 1.0, F=0.500
x= 1.5, F=1.125
x= 2.0, F=2.000
x= 2.5, F=3.125
x= 3.0, F=4.500
x= 3.5, F=6.125
x= 4.0, F=8.000
- 03.07.2018 10:13
- thumb_up 36
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.