Вопрос по информатике:
Помогите написать программу на Pascal
Из трехзначного числа X вычли его последнюю цифру. Когда результат разделили на 10, а к частному слева приписали последнюю цифру числа X. То получилось число N. По заданному N найти число X (значение N вводится с клавиатуры, 10<=N<=999 , и при этом число десятков в N не равно нулю).
- 02.05.2015 13:31
- Информатика
- remove_red_eye 7501
- thumb_up 11
Ответы и объяснения 1
Если было число ABC = X, то после деления на 10 стало AB, а после приписывания слева CAB = N. Для получения из N числа X просто переставляем первую цифру в конец.
var
N: integer;
begin
readln(N);
write(10 * (N mod 100) + (N div 100))
end.
- 03.05.2015 14:02
- thumb_up 40
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.