Вопрос по информатике:
Входной замок Лисы Алисы работает следующим образом:
если введено натуральное число, которое меньше 100 или больше 999 – на дисплее устройства появляется надпись «FALSE»;
если у введённого числа сумма цифр равна 13 – появляется надпись «ENTER» и можно войти;
в остальных случаях появляется надпись «LOCK».
Входные данные: натуральное число N ( ).
Выходные данные: необходимо вывести надпись, которая должна быть на дисплее.
Пример:
Ввод Вывод
2 FALSE
427 ENTER
318 LOCK
- 10.03.2018 00:56
- Информатика
- remove_red_eye 18372
- thumb_up 32
Ответы и объяснения 1
Var
n,e,d,s,sum: integer;
begin
writeln ('vvedi cislo n');
read (n);
if (n999) then writeln ('False');
if (n>100) and (n<999) then
begin
e:= (n mod 10);
writeln ('e',e);
s:=(n div 100);
writeln ('s',s);
d:=(n div 10)-s*10;
writeln ('d',d);
sum:=s+d+e;
writeln ('sum',sum);
if sum=13 then writeln ('Enter')
else
writeln ('Lock');
end;
end.
- 01.01.1970 00:00
- thumb_up 21
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.