Вопрос по информатике:
Написать программу(Delphi или Pascal) для вычисления минимального произведения отрицательных подряд идущих элементов одномерного массива.
- 21.12.2017 06:58
- Информатика
- remove_red_eye 6642
- thumb_up 18
Ответы и объяснения 1
Const n=10 ;var A: array [1..n] of integer;p, min, i, : integer;beginrandomize;for i:= 1 to n dobeginA[i]:= -100 + random (200);write (A[i]: 5);end;writeln;min:=100000000;p:=1;for i:=1 to n doif A[i] < 0 then p:=p*A[i] else Begin if p< min then min:=p; p:=1; End; if p
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.