Вопрос по информатике:
ПАСКАЛЬ. Вова попал на космическом корабле на бесконечную плоскую планету в точку с координатами (x1, y1). Вова, управляя кораблем, имеет возможность за одну секунду телепортироваться из точки (x, y) в одну из точек (x+C, y+C), (x+C, y-C), (x-C, y+C), (x-C, y-C), где C - произвольное натуральное число, которое можно изменять на каждом ходу.
Требуется написать программу, которая определит, через какое минимальное время Вове удастся достичь точки (x2, y2).
Входные данные
Входной файл INPUT.TXT содержит в первой строке числа x1, y1, во второй – x2, y2. Все числа целые от нуля до 106. Точки (x1, y1) и (x2, y2) не совпадают.
Выходные данные
Выходной файл OUTPUT.TXT должен содержать одно число – минимальное время телепортации. Если такая телепортация невозможна, то вывести 0.
- 08.01.2018 23:54
- Информатика
- remove_red_eye 15545
- thumb_up 49
Ответы и объяснения 1
1. Заметим, что такими манипуляциями нельзя поменять чётность произведения xy, где (x, y) - текущие координаты корабля. Если угодно, можно представить бесконечное поле для шахмат, корабль ходит как слон - только по диагонали, поэтому цвет поля не меняется.
2. Естественно "развернуть" координаты так, чтобы "горизонтальное" и "вертикальное" направления были вдоль диагоналей. Это делается путем преобразования x' = x + y, y' = x - y.
3. В новых координатах корабль может ходить по горизонтали и вертикали, при этом в любую достижимую точку он придет не более чем за 2 шага. За 1 шаг он придет, если стоит в той же горизонтали или вертикали.
4. Для простоты сдвинем начало координат в начальную точку, тогда точка назначения будет иметь координаты x' = (x2 - x1) + (y2 - y1), y' = (x2 - x1) - (y2 - y1)
Решение, PascalABC.NET:
begin
var inf := OpenRead('INPUT.TXT');
var outf := OpenWrite('OUTPUT.TXT');
var x1, x2, y1, y2: longint;
read(inf, x1, y1, x2, y2);
if (x1 * y1 - x2 * y2) mod 2 = 0 then
begin
(x2, y2) := ((x2 - x1) + (y2 - y1), (x2 - x1) - (y2 - y1));
if x2 * y2 = 0 then
write(outf, 1)
else
write(outf, 2);
end
else
write(outf, 0);
close(inf);
close(outf);
end.
- 09.01.2018 10:36
- thumb_up 34
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.